1

I am on Debian and getting Debian from Debian itself after which it updates tor from the web.

Now the path of Tor Browser has changed slightly it seems from

/home/shirish/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/start-tor-browser

it has now changed to

/home/shirish/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/start-tor-browser.desktop

Trying to launch it I get the following -

[$] ./start-tor-browser.desktop                                                                                                     
Launching './Browser/start-tor-browser --detach'...
./Browser/execdesktop: line 14: ./Browser/start-tor-browser: No such file or directory

Update -

Trying to launch it with torbrowser-launcher I get the same error -

[$] torbrowser-launcher                                                                                                             
Tor Browser Launcher
By Micah Lee, licensed under MIT
version 0.2.7
https://github.com/micahflee/torbrowser-launcher
Launching './Browser/start-tor-browser --detach'...
./Browser/execdesktop: line 14: ./Browser/start-tor-browser: No such file or directory

Any ideas ?

  • This is torbrowser-launcher that you're using? (it's totally unrelated to the tor package on apt). Have you tried opening it using the torbrowser-launcher program itself? – cacahuatl Jul 7 '17 at 22:07
  • I updated my query with the info. you asked, the result is the same. I could simply remove tor and the related binaries and try afresh but would like to do as a last resort. – shirish Jul 8 '17 at 0:23
  • does the file /home/shirish/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/start-tor-browser exist? – cacahuatl Jul 8 '17 at 13:28
  • it existed before, now it does not, after the update, hence the question what to do. – shirish Jul 8 '17 at 17:33
  • Reinstall Tor Browser – cacahuatl Jul 9 '17 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.