1

As title says, just wondering if anyone else is experiencing this issue. I have enabled NS and the whitelist is empty.

NS seems to be 'trusting' everything by default unless I mark each entry on a page specifically as Untrusted.

What happens on Google Maps after forbidding scripts globally: enter image description here

I have to manually mark every site as 'Untrusted' on this page, hit F5 and only then do I get the expected result:

enter image description here

I cannot figure out why NS is whitelisting everything by default unless I specify otherwise....

1

Google Maps in the browser does not use Java but Javascript. No Script is great at blocking Javascript from loading and running at all.

You need to make sure No Script is set to block everything globally ("Forbid Scripts Globally").

Then whitelist specific sites and scripts as needed for the functionality you need per domain.

enter image description here

  • Edited OP for clarity. Obviously this first step has already been taken :P – Chris Jul 6 '17 at 4:20
  • @Chris thanks I should have commented in your question and asked for clarification instead of answering right away. When you say "enabled NS" that is a little vague because firefox addons can be enabled and disabled. I think being super specific and precise about the exact nature of the bug is better. "I have forbid scripts globally in the addon settings". Also you still have the question tagged as Java which this is not a Java issue. – jamescampbell Jul 6 '17 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.