1

Sorry to bother you guys, but Tor browser 7.x doesn't work for me, no matter what OS I use.

To cut it short, I have Tor browser 6.5.2 running fine on my windows 7 desktop computer, a few day ago it automatically downloaded 7.0 update, the next time I try to run it, the progress bar stuck at 'retrieving network status' stage, waiting overnight and nothing happens.

Suspecting a corrupted update, I deleted that installation, rolled back to a clean 6.5.2 browser, and downloaded a fresh 7.0 installation file, loaded the same set of obfs4 bridges to the newly installed Tor browser7.0, and it didn't help, when I run it, the progress bar still stuck at 'retrieving network status'.

Alarmed, I checked the log file, and witnessing a crapload of ''Ignoring directory request, since no bridge nodes are available yet." warning, also the exact place where the bootstrap process got stuck is '25% asking for network consensus'.

Since I also have a flashdisk loaded with tails 2.12, I decided to do a signature verification, both 6.5.2 binary file and 7.0 turned out ok.

To rule out any antivirus false-positive or network hardware/driver based failures, I booted from tails 2.12, and downloaded a fresh image of tails 3.0 through Tor browser, and burned it to a DVD disk, when I booted from the tails 3.0 DVD, and try to connect to tor network, again using the same set of obfs4 bridges, the same symptom happens, the progress bar won't go past 'retrieving network status' stage. A quick look through the log created again revealing a series of 'Ignoring directory request, since no bridge nodes are available yet.' warning, occasionally, 'I learned some more directory information, but not enough to build a circuit: We have no usable consensus. ' appears. Waiting for hours doesn't make any differences.

From those symptoms, I can only draw the conclusion that either this particular version of Tor browser has some pluggable transport related coding issue, or the country I live in has come up with some particular effective measure to attack the bootstrapping process of tor browser 7.0.

I'm at a total loss here, can anyone share their experience with TBB7.0 or tails 3.0?

BTW my ISP is China telecom.

Edit: This is the log generated by TBB 7.0 under windows platform:

2017/6/16 9:55:11.900 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
2017/6/16 9:55:11.900 [NOTICE] Switching to guard context "bridges" (was using "default")
2017/6/16 9:55:11.900 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
2017/6/16 9:55:11.900 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
2017/6/16 9:55:11.900 [NOTICE] Opening Socks listener on 127.0.0.1:9150 
2017/6/16 9:55:11.900 [NOTICE] Renaming old configuration file to "F:\Tools\Network\Standard\Tor Browser700f\Browser\TorBrowser\Data\Tor\torrc.orig.1" 
2017/6/16 9:55:19.000 [NOTICE] Bootstrapped 5%: Connecting to directory server 
2017/6/16 9:55:19.000 [NOTICE] Bootstrapped 10%: Finishing handshake with directory server 
2017/6/16 9:55:22.400 [NOTICE] Bootstrapped 15%: Establishing an encrypted directory connection 
2017/6/16 9:55:22.700 [NOTICE] Bootstrapped 20%: Asking for networkstatus consensus 
2017/6/16 9:55:23.500 [NOTICE] new bridge descriptor 'ndnop5' (fresh): $BBB28DF0F201E706BE564EFE690FE9577DD8386D~ndnop5 at 109.105.109.147 
2017/6/16 9:55:23.500 [NOTICE] I learned some more directory information, but not enough to build a circuit: We have no usable consensus. 
2017/6/16 9:55:24.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:55:25.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:55:29.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:55:29.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:55:35.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:55:35.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
a list of bridges with general socks failure.
2017/6/16 9:55:54.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:55:56.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:56:26.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:57:10.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 9:57:41.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 10:01:50.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 10:02:16.500 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 10:13:51.600 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 10:15:23.600 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
a list of bridges with general socks failure.
2017/6/16 10:32:19.600 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
2017/6/16 10:33:19.600 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
a list of bridges with general socks failure.
2017/6/16 11:17:50.900 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
a list of bridges with general socks failure.
2017/6/16 11:26:50.000 [NOTICE] new bridge descriptor 'Azadi' (fresh): $FE7840FE1E21FE0A0639ED176EDA00A3ECA1E34D~Azadi at 154.35.22.13 
2017/6/16 11:26:50.000 [NOTICE] I learned some more directory information, but not enough to build a circuit: We have no usable consensus. 
2017/6/16 11:28:53.300 [NOTICE] Bridge 'NX01' has both an IPv4 and an IPv6 address.  Will prefer using its IPv4 address (85.17.30.79:443) based on the configured Bridge address. 
2017/6/16 11:28:53.300 [NOTICE] new bridge descriptor 'NX01' (fresh): $FC259A04A328A07FED1413E9FC6526530D9FD87A~NX01 at 85.17.30.79 
2017/6/16 11:28:53.300 [NOTICE] I learned some more directory information, but not enough to build a circuit: We have no usable consensus. 
a list of bridges with general socks failure.
2017/6/16 11:33:46.200 [NOTICE] new bridge descriptor 'MaBishomarim' (fresh): $A832D176ECD5C7C6B58825AE22FC4C90FA249637~MaBishomarim at 154.35.22.11 
2017/6/16 11:33:46.200 [NOTICE] I learned some more directory information, but not enough to build a circuit: We have no usable consensus. 
2017/6/16 11:34:01.800 [WARN] Proxy Client: unable to connect to 198.245.60.50:443 ("general SOCKS server failure") 
2017/6/16 11:36:22.800 [WARN] Proxy Client: unable to connect to 192.99.11.54:443 ("general SOCKS server failure") 
2017/6/16 11:38:39.100 [NOTICE] Ignoring directory request, since no bridge nodes are available yet. 
a list of bridges with general socks failure.
2017/6/16 12:04:32.100 [NOTICE] Closing no-longer-configured Socks listener on 127.0.0.1:9150 
2017/6/16 12:04:32.100 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
2017/6/16 12:04:32.100 [NOTICE] Closing old Socks listener on 127.0.0.1:9150 
2017/6/16 12:04:33.000 [NOTICE] Delaying directory fetches: DisableNetwork is set. 

I think I have hit the character limitation of the post...

  • You could try a different set of bridges or pluggable transport. The "I learned some more directory information, but not enough to build a circuit" line suggests that you're able to connect but potentially the connection is being throttled. – cacahuatl Jun 16 '17 at 12:26
  • Also ensure your date/time are accurate, obfs4 will not work if your time is off by more than an hour either direction. – cacahuatl Jun 16 '17 at 19:56
  • Sorry for the incredibly late reply, but no, I checked both my timezone and time setting, they're accurate. – Annon35 Jun 27 '17 at 3:17
  • BTW, this does not seems to be a bridge related issue, since the TBB7.0 I'm using 'inherited' the same set of bridges from TBB 6.5.2 when it automatically updated itself. If those bridges are all down, then how come the older version work? – Annon35 Jun 27 '17 at 3:29
  • Tails 3.0 and TB 7.0 work for me across various operating systems, with or without bridges. Can you provide a full Tor log? – cacahuatl Jun 27 '17 at 22:08
0

I've found a temporary workaround on Windows platform.

When TBB has issue connecting, check the log, if Tor is able to at least partially fetching directory info,(shown in the log as I learned some more directory information, but not enough to build a circuit:) but the progress bar doesn't want to move forward for hours, simply shut down the browser, wait for a few minutes, and restart, sometimes it will get through, might still take hours through...

Now switching to Lantern, Psiphon and freeVPN, hopefully Tor bug team can correct this issue in a future release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.