1

I am using TBB quite a while, currently in version 7.0 on Ubuntu studio. Just recently I came across a strange behaviour of noscript, that probably might not be intended: When i visit a site and manually allow all scripts, the noscript-icon changes from red to white. If I decide to change identity via Onion button ("New Identity") and visit the same site again, the noscript-icon will change back to red, but in fact, all scripts are allowed. I have tried several sites, it is everywhere the same bevaviour. Do I have wrong settings in noscript? Or is it a bug? Thank you for your answers!

edit: I have updated to 7.0.1, but nothing has changed. With manually allow scripts I mean "Temporarily allow all this page". Ubuntu Studio 16.04.2 LTS. Tor Network Settings: nothing checked Security Settings: High. Browser Settings are unchanged. I don't think, that I have changed any NoScript settings. If so, only on General Tab.
1. As expected
1. As expected
2. Temporarily allow all this page + New Identity + Load Site again
2. Temporarily allow all this page + New Identity + Load Site again

EDIT: I think no one could reproduce this behaviour, and for me it was gone after a fresh reinstall of TBB 7.0.1.
Thank you!

2
  • This sounds indeed like a bug. I can't reproduce the issue though. Can you update to the just released version 7.0.1 and retry? Since JS is disabled by default, I assume you set the security slider to high. Is this correct? Did you change any other settings? – Peter Gerber Jun 13 '17 at 21:14
  • When you say you "manually allow all scripts" do you mean "All Scripts Globally" or "Temporarily All This Page"? All Scripts Globally will persist through newnym, temporarily will not. – cacahuatl Jun 14 '17 at 3:59