I saw OrBot in Google PlayStore and decided to give it a shot. Once I enabled apps VPN mode and Bridges (just to see...) I started getting a lot of captchas. When I searched online for what could be done, I read somewhere that this can be solved by requesting different bridges from tor (they said it was due to lot of traffic from the bridge I was using). So I took some new bridges from tor. But now, when I start tor, it doesn't start. The log says this:

Set background service to FOREGROUND
Orbot is starting…
Orbot is starting…
updating settings in Tor service
hidden services are enabled
updating torrc custom configuration...
Orbot is starting…
Waiting for control port...
Connecting to control port: 35369
SUCCESS connected to Tor control port.
SUCCESS - authenticated to control port.
Starting Tor client… complete.
adding control port event handler
SUCCESS added control port event handler
Tor started; process id=9941
Starting polipo process
Polipo is running on port:8118
Polipo is running
NOTICE: Bridge at 'x.x.x.x:y' isn't reachable by our firewall policy. Asking bridge authority instead. 
NOTICE: While fetching directory info, no running dirservers known. Will try again later. (purpose 6) 
NOTICE: Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit) 
TorService is shutting down
Using control port to shutdown Tor
sending HALT signal to Tor process
Orbot is deactivated

So whats wrong with this? Why ain't it starting? Please tell some layman answer for how I can solve this, or perhaps also a solution for getting rid of those captchas. Also note that I am using orbot app in android 6, so I don't feel like much coding can be done there. Thanks in advance :)

  • JFTR: You'll see CAPTCHAs with or without bridges. Certain websites are behind CloudFlare and they have some checks enabled. When you visit them via a Tor connection, you'll see the CAPTCHA.
    – Jens Kubieziel
    Commented May 29, 2017 at 20:00
  • I downloaded the Android version and it says tor is connected but when I click browse this is what I get ?? What do I need to do to fix this . This is my very first time every using something like this and I just started researching untraceable internet and tor is what came up and was recommended sebrb Commented Jul 27, 2017 at 10:56

1 Answer 1


You've appear to have specified ReachableAddresses which means that you've told Tor is can't reach certain destinations, those destinations include the bridges that you've been given so Tor is avoiding connecting to them:

NOTICE: Bridge at 'x.x.x.x:y' isn't reachable by our firewall policy.

You need to go into your settings and remove the limitations you've set on reachable addresses or ports by going into the Settings menu and going to the ReachableAddresses section.

  • Works perfect now, thanks! BTW could you also help me out with those irritating captchas? Is there any way I can get rid of them? Commented May 27, 2017 at 3:28
  • Unfortunately not, no. They're there because Tor Exit nodes often have poor reputations, because some people use Tor in way that the site doesn't like (e.g. comment spam, scraping/crawling, etc). They're designed not to be gotten around.
    – cacahuatl
    Commented May 27, 2017 at 18:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .