2

I've looked through the existing descriptions and tried many ways to do this - but don't believe it's ever worked for me.

I have a Windows 7 pro machine which has been running for years with only two applications - Open VPN and Privoxy. Both run from a guest account and supply web access & DNS to all other PCs here. This machine runs 24/7.

Would like to install a manually started tor middle relay, but it sems everything I try fails to get the torrc recognized by the tor.exe file. But when I manually start tor.exe with admin priviledges from that same guest account - it indicates it can build working circuits from it's default.

I don't need tor access (have other ways for that) - just wish to provide relay capacity while keeping these activities hidden from our ISP (who I detest). Have a second identical gateway going to a different VPN which I might be willing to convert also - if I could just get the first to work.

Believe I found the main problem....torrc had a hidden .txt suffix (rolling eyes). Now it shows to be reading the configuration.

New problem? It claims I haven't inserted contact information - but I believe I have.

Apr 23 14:12:40.799 [notice] Tor 0.2.9.10 (git-1f6c8eda0073f464) running on Windows 7 with Libevent 2.0.22-stable, OpenSSL 1.0.2k and Zlib 1.2.8.
Apr 23 14:12:40.799 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Apr 23 14:12:40.819 [notice] Read configuration file "C:\Users\VPNProxy\AppData\Roaming\tor\torrc".
Apr 23 14:12:40.829 [warn] Path for GeoIPFile (<default>) is relative and will resolve to C:\Users\Guest\tor\tor\<default>. Is this what you wanted?
Apr 23 14:12:40.829 [warn] Path for GeoIPv6File (<default>) is relative and will resolve to C:\Users\Guest\tor\tor\<default>. Is this what you wanted?
Apr 23 14:12:40.829 [notice] Your ContactInfo config option is not set. Please consider setting it, so we can contact you if your server is misconfigured or something else goes wrong.
Apr 23 14:12:40.829 [notice] Based on detected system memory, MaxMemInQueues is set to 1535 MB. You can override this by setting MaxMemInQueues by hand.
Configuration was valid

What am I missing here?

Update. This is my current torrc:

Security refinements welcomed. I'm very nervous tor relay only functions with admin privileges.

 ORPort 9803
 Nickname worfdog
 RelayBandwidthRate 100 KBytes
 ContactInfo Bat Shit <services+torelay AT doemail.org>
 DirPort 10803
 Exitpolicy reject *:*
  • 2
    The ContactInfo isn't required, its just helpful. The logs look fine, it's starting properly. Can you provide the contents of the torrc file too? – cacahuatl Apr 23 '17 at 20:28
  • How can I get this file to you? When I paste it into the original help request window - it strips out the pound sign comment symbols. Can't find a way to attach the file either. – Batshit Apr 23 '17 at 23:57
  • It probably doesn't strip them, they're likely being used as the markdown symbols, instead put 4 spaces infront of the lines to mark them as "pre-formatted", or use the button to mark them as pre-formatted/code so they're not interpreted as markdown. – cacahuatl Apr 24 '17 at 3:27
  • Arrg, only inserted 1 space. And it screwed up. Sorry. – Batshit Apr 24 '17 at 11:35
  • The likelihood is that Tor isn't using the torrc you've provided. When you start tor, issue the command tor with the -f flag followed by the path to your torrc. – cacahuatl Apr 24 '17 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.