0

I am behind college proxy and trying to run a tor daemon on my system. My torrc configuration is

HTTPSProxy 172.30.0.23:3128

UseBridges 1
 # This works for Ubuntu Linux, adjust the path according to your platform
 #ClientTransportPlugin obfs4,obfs3 exec /usr/local/bin/obfs4proxy managed

Bridge obfs4 <bridgeip>:<port> 71C023CF72CAD644FE0FA04C0EA8F840FD562C30 cert=bar8dxwmy5aM/OsRNIUNlLuipQen/NB1w81YhBIGJl89JiqZ+6uih/k4f3VjqjfJ13x4Gw iat-mode=0

On running tor daemon using sudo service tor start I am getting following error

 * Checking if tor configuration is valid
Mar 01 13:11:33.412 [notice] Tor v0.2.4.27 (git-412e3f7dc9c6c01a) running on Linux with Libevent 2.0.21-stable and OpenSSL 1.0.1f.
Mar 01 13:11:33.412 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Mar 01 13:11:33.412 [notice] Read configuration file "/usr/share/tor/tor-service-defaults-torrc".
Mar 01 13:11:33.412 [notice] Read configuration file "/etc/tor/torrc".
Mar 01 13:11:33.415 [warn] Key digest for Bridge is wrong length.
Mar 01 13:11:33.415 [warn] Failed to parse/validate config: Bridge line did not parse. See logs for details.
Mar 01 13:11:33.415 [err] Reading config failed--see warnings above.

My college bans tor traffic.

After adding EtorPort auto new config is

 HTTPSProxy 172.30.0.23:3128

UseBridges 1
 # This works for Ubuntu Linux, adjust the path according to your platform
 ClientTransportPlugin obfs4,obfs3 exec /usr/local/bin/obfs4proxy managed

ExtORPort auto

Bridge obfs4 <proxy>:<port> 71C023CF72CAD644FE0FA04C0EA8F840FD562C30 cert=bar8dxwmy5aM/OsRNIUNlLuipQen/NB1w81YhBIGJl89JiqZ+6uih/k4f3VjqjfJ13x4Gw iat-mode=0

I am getting following error message

* Checking if tor configuration is valid
Mar 01 20:55:01.148 [notice] Tor v0.2.4.27 (git-412e3f7dc9c6c01a) running on Linux with Libevent 2.0.21-stable and OpenSSL 1.0.1f.
Mar 01 20:55:01.148 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Mar 01 20:55:01.148 [notice] Read configuration file "/usr/share/tor/tor-service-defaults-torrc".
Mar 01 20:55:01.148 [notice] Read configuration file "/etc/tor/torrc".
Mar 01 20:55:01.150 [warn] Failed to parse/validate config: Unknown option 'ExtORPort'.  Failing.
Mar 01 20:55:01.150 [err] Reading config failed--see warnings above.
0

You need to install obfs4proxy and uncomment the line ClientTransportPlugin obfs4,obfs3 exec /usr/local/bin/obfs4proxy managed - it will tell Tor "what is obfs4" bridge backend. It's obviously can't parse the Bridge directive - because obfs4 must be "defined" before used.

UPDATE: You seem to experience a double-proxying case, this is only a problem in versions of Tor prior to 0.2.6.x. If you will take a look here at obfs4 source code you will see that it actually understands HTTPS proxy and this was the correct proxy configuration point, because a pluggable transport is a "proxy" for tor - it wraps it's own communication through it in the same manner, that what it is complaining about. So - in your torrc config your line HTTPSProxy 172.30.0.23:3128 must be commented out. But how to use your proxy by obfs4? It uses Go language and the golang.org/x/net/proxy Dialer in particular, which expects your proxy data to be in the environment. You should set *in your Tor user shell profile * the next lines:

export http_proxy=172.30.0.23:3128
export HTTP_PROXY=172.30.0.23:3128
export https_proxy=172.30.0.23:3128
export HTTPS_PROXY=172.30.0.23:3128

they are for Bash and Sh, if you're using different shell - please check it's manual

  • After uncommenting ClientTransportplugin line I am getting following error Mar 01 19:00:16.423 [warn] Failed to parse/validate config: You have configured more than one proxy type. (Socks4Proxy|Socks5Proxy|HTTPSProxy|ClientTransportPlugin) – niks2010 Mar 1 '17 at 13:30
  • I have already installed obfs4proxy. And how to use ExtORPort auto line, it is also giving error. Thanks for your reply. :) – niks2010 Mar 1 '17 at 13:33
  • Add extorport line to your config file - what error it gives you? can you update question with your new config, please? – Alexey Vesnin Mar 1 '17 at 13:34
  • Please try the configuration I suggest and let's see what's happen – Alexey Vesnin Mar 1 '17 at 16:56
  • After commenting out HTTPSProxy line, my tor daemon is running. Thanks a lot. But ExtORPort auto it was showing same error "Unknown option ExtORPort". But after commenting out ExtORPort line, tor daemon is running. Thanks for your help. :) – niks2010 Mar 1 '17 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.