3

As mentioned in stem.torproject:

If your torrc doesn't have a CookieAuthentication or HashedControlPassword then to authenticate you will simply call AUTHENTICATE after connecting without any credentials.

So I commented out both CookieAuthentication 1 and HashedControlPassword 16:E600ADC1B52C80BB6022A0E999A7734571A451EB6AE50FED489B72E3DF in my torrc file.

Then I restarted Tor and tried to connect by just by issuing AUTHENTICATE, without any credential. But I got the following error:

515 Authentication failed: Password did not match HashedControlPassword value from configuration. Maybe you tried a plain text password? If so, the standard requires that you put it in double quotes.

My question is, How can I login without any credential? I am using Tor Browser Bundle 6.5 on my Windows 10.

-torrc-default file-

AvoidDiskWrites 1
Log notice stdout
SocksPort 9150 IPv6Traffic PreferIPv6 KeepAliveIsolateSOCKSAuth
ControlPort 9151
ClientTransportPlugin fte exec TorBrowser\Tor\PluggableTransports\fteproxy --managed
ClientTransportPlugin obfs2,obfs3,obfs4,scramblesuit exec TorBrowser\Tor\PluggableTransports\obfs4proxy
ClientTransportPlugin meek exec TorBrowser\Tor\PluggableTransports\terminateprocess-buffer TorBrowser\Tor\PluggableTransports\meek-client-torbrowser -- TorBrowser\Tor\PluggableTransports\meek-client
#CookieAuthentication 1
#HashedControlPassword 16:E600ADC1B52C80BB6022A0E999A7734571A451EB6AE50FED489B72E3DF

Note: I tried both commenting out and removing both lines.

-torrc file-

Bridge obfs4 198.<omitted for public post> iat-mode=0
Bridge obfs4 37.<omitted for public post> iat-mode=0
Bridge obfs4 151.<omitted for public post> iat-mode=0
DataDirectory C:\Users\Sourav\Desktop\Tor Browser\Browser\TorBrowser\Data\Tor
GeoIPFile C:\Users\Sourav\Desktop\Tor Browser\Browser\TorBrowser\Data\Tor\geoip
GeoIPv6File C:\Users\Sourav\Desktop\Tor Browser\Browser\TorBrowser\Data\Tor\geoip6
HiddenServiceStatistics 0
UseBridges 1

Still getting:

250-PROTOCOLINFO 1

250-AUTH METHODS=HASHEDPASSWORD

250-VERSION Tor="0.2.9.9"

250 OK

Screenshot of Tor data directory:

screenshot tor data directory

I have also tried AUTHENTICATE ""but failed.

enter image description here

  • Where did you comment them out? – cacahuatl Feb 22 '17 at 0:44
  • in torrec-defaults. I know this is not recommended because this file may get overwritten during Tor upgrade. but I was just trying things out. CookieAuthentication 1 was already present there. I commented it out first and added HashedControlPassword 16:E600ADC1B52C80BB6022A0E999A7734571A451EB6AE50FED489B72E3DF and it worked fine. authenticated using the password. then I commented out that line too. – Sourav Ghosh Feb 22 '17 at 5:41
  • It should work, some authentication is definitely being defined somewhere. What happens if you send it PROTOCOLINFO instead of AUTHENTICATE? It should give back a line saying 250-AUTH METHODS=NULL, and have you accidentally defined some in torrc which is being applied after torrc-defaults? – cacahuatl Feb 22 '17 at 9:29
  • @canonizingironize edited the question with additional info. Is there any chance that they apply default authentication method to HashedControlPassword ? I have also posted a screenshot of Tor data directory. No other config file is there. – Sourav Ghosh Feb 22 '17 at 10:16
  • No, the default is definitely with no authentication, the manual has a big warning about that and I have tested it. Are you starting Tor by running the Tor Browser itself or running tor.exe from the command line or something? – cacahuatl Feb 22 '17 at 12:00
1

set CookieAuthentication 0
if you had HashedControlPassword removed it

$ telnet 127.0.0.1 9051
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
AUTHENTICATE
250 OK
-1

The working syntax for null authentication to the control port is as:

authenticate ""

[Edited : The documented syntax which you tried, just authenticate, without parameters, is not accepted by Tor (depending on versions) ]

  • PROTOCOLINFO still shows 250-AUTH METHODS=HASHEDPASSWORD and I tried your solution too but didn't work. It showed "515 Authentication failed: Password did not match HashedControlPassword value from configuration" – Sourav Ghosh Feb 22 '17 at 10:58
  • 1
    Incorrect, simply sending AUTHENTICATE is still entirely valid and works. Maybe you should try dong a simple test first? – cacahuatl Feb 22 '17 at 11:58
  • I wouldn't write a thing I haven't checked and verified. I have been running successive versions of Tor on Windows assiduously for ca 15 years, and issuing auth and other commands thru the control port for as much time. AUTHENTICATE by itself would work in the good ol'days, but it ceased working at some point in the past, givng the exact error reported by the OP. I found experimnentaly the workaround in above ANSWER. Has worked for me since. Other versions/platforms maybe different – Noino O Feb 22 '17 at 12:43
  • Amendment : it does differ by Tor versions, even on Windows. Just checked current 0.3.0.3-alpha, indeed AUTHENTICATE is accepted with a blank argument again. But it was not for several earlier versions, I had to edit my (a lot of) scripts for this so... depending on which exact tor the OP is using, he might try the proposed solution. – Noino O Feb 22 '17 at 13:00
  • Tell me a version that doesn't accept it on Windows :) – cacahuatl Feb 22 '17 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.