1

Dearest Group,

Installed on Ubuntu 16.04 from Torproject (Xenial) repository. In the torrc config file - 'RunAsDaemon 1' is un-commented.

The log file shows 'Catching signal TERM, exiting cleanly' as the last event. Examining the tor service status shows 'active (exited)'.

I can only invoke tor as 'sudo' on the command line.

UPDATE

Commenting out RunAsDaemon and reboot results in the same. Additionally, nothing new is appended to the log file. I have also invoked #service tor start.

LAST UPDATE

As what was happening to me was not making much sense, I elected to go for a re-build. I then re-read the instructions, specifically:

  1. Edit torcc config file - leave daemon line commented out and make necessary changes for a relay
  2. (root) service tor reload
  3. Inspect the log file - /var/log/tor/log

Now working

Any ideas?

Thanks in advance,

Richard

4
  • Why did you uncomment RunAsDaemon 1? This is likely confusing the service manager which isn't expecting tor to fork into a daemonized process.
    – cacahuatl
    Jan 2, 2017 at 7:50
  • I have commented out the RunAsDaemon. Post updated.
    – Richard
    Jan 2, 2017 at 10:49
  • Have you tried to setup Tor Browser to use this or something? Could we see the rest of the log?
    – cacahuatl
    Jan 3, 2017 at 3:46
  • Thanks for taking the time to help - please see final comment appended.
    – Richard
    Jan 3, 2017 at 17:34

1 Answer 1

1

Using Ubuntu/Debian pre-packaged scripts is very troublesome, so I'm using daemontools and screen to launch the "process in screen" with RunAsDaemon 0 and re-launching it via daemontools. The root of such a problem is deep inside the startup scripts for SystemD, because old ones for Ubuntu/Debian that used a SysV.init scripts seemed to be working almost fine(I've heard and solved some minor issues, usually happening after automatic updates). My technique is using combined monitoring/heartbeat script in daemontools and launching in /etc/rc.local and re-launching in daemontools script a process inside a GNU Screen in foreground mode. It works fine, trouble-proof even in automatic upgrades case. If you need further assistance in launching Tor in daemontools? just say it - I'm glad to help!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .