0

I am having trouble loading all the content at extratorrent.cc. I get past the Captcha fine, then the page loads but with none of the torrent content. And searching for a torrent file doesn't work either. I just have a consistent blank white space in the page. I have temporarily allowed scripts in the torbrowser toolbar and tried changing identity too.

This has been an issue for me for a few weeks now. Very occassionaly the site 'works' but then goes back to the same problem described.

  • Looks like it's their site that's broken. – cacahuatl Dec 31 '16 at 17:23
0

It seems that exit nodes that are used are mostly blocked, I had this situation when I was trying to use a webmail - it said that sending is impossible because of spam listing of the client IP. In this case nothing than "try and change exit" will work, I'm afraid. Also take a look at network activity tab or install Firebug - sometimes some in-JS requests are failing silently, and that's why it can be broken.

| improve this answer | |
  • How do you know they're blocked? – cacahuatl Jan 1 '17 at 19:51
  • from the words of the question. It seems like exact situation I solved. – Alexey Vesnin Jan 1 '17 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.