0

I have a problem. When I want to connect to the pseudo-domain onion tor return me information:

[Warn] Refusing to connect to the IPv6 address [scrubbed] because Port has NoIPv6Traffic set.

To the Torrc file I added lines:

DNSPort 9053
AutomapHostsOnResolve 1
AutomapHostsSuffixes .exit,.onion

What should I do?

Normal domains work good.

--- update to comment

I checked it. In the file I can have only this three lines. Something I should add?

1

If IPv6 working in your setup? i.e. it can be disabled in sysctl or in kernel - so no AutomapHosts-like features will work with IPv6, if it's disabled in OS. Also here some check-list:

  • GeoIPv6File must be specified,
  • In OrPort no flag IPv4Only must be specified,
  • ClientPreferIPv6ORPort should be set to auto,
  • ClientUseIPv6 should not be set to 0
  • VirtualAddrNetworkIPv6 - if using AutomapHosts - can be also used and it's a big bonus
  • PreferIPv6Automap - set it to on if you're preferring IPv6
  • PreferIPv6 and IPv6Traffic are enabling you to use IPv6 for exits - use these flags in SocksPort line, by default SOCKS in Tor does not handle IPv6! <<---- this can be your particular case due to the error message you've posted

Try to add the strings needed to your torrc explicitly. If you will still have problems - drop me a line, we'll se further.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.