I'm having some issues getting my relay up and running with Ubuntu. I have one running on Debian with no issues, so hopefully someone can give me a hand.

I followed the torproject instuctions: You need to add the following entry in /etc/apt/sources.list or a new file in /etc/apt/sources.list.d/:

deb http://deb.torproject.org/torproject.org xenial main

deb-src http://deb.torproject.org/torproject.org xenial main

Then add the gpg key used to sign the packages by running the following commands at your command prompt:

gpg --keyserver keys.gnupg.net --recv 886DDD89 gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -

You can install it with the following commands:

$ apt-get update

$ apt-get install tor deb.torproject.org-keyring

I've double checked my version and everything there is correct.

I then edit my torrc

with

ORPort 443

ExitPolicy reject *:*

log notice /var/log/tor/notices.log

Nickname ****

But I run the service and nothing populates in the log file (in fact notice.log is never created).

The service is marked as running/ran but then I get the "Interrupt: exiting cleanly" message but I don't know where/why that is coming from. Has anyone encountered this? And if so, how did you resolve it?

  • 2
    That line should be Log notice file /var/log/tor/notices.log – cacahuatl Sep 18 '16 at 22:10
  • Have you ever felt so dumb you wanted to die? That's me right now. Apparently, my Nickname exceeded the character limit. Thank you though, you definitely solved me problem. ORPort is now reachable. – T.J. Sep 19 '16 at 23:27

As my experience has shown - there's no way to capture all the output data,especially the crush case ones. Use GNU Screen with 2>&1 and data logging for this - no other way is fully working. Run Tor in foreground in that case

  • Why downvote if you don't know what you're talking about? Log directive does not capture crush data/trace – Alexey Vesnin Sep 21 '16 at 16:06
  • 1
    That wasn't I who downvoted. – T.J. Sep 21 '16 at 19:37
  • @T.J. do you need instructions on how to make it work? – Alexey Vesnin Sep 21 '16 at 20:18
  • I figured it out. I starred out my nickname, but it was one character too long, so the torrc wouldn't be validated to even create the log. Thank you for reaching out. My middle relay is now up and running. – T.J. Sep 23 '16 at 18:38
  • @T.J. but if that was an issue with invalid string - was Tor even starting? Or - if it started - it should point you to exact "bad line number" and say explicitly that it's an error - in stdout in foreground mode(RunAsDaemon 0) – Alexey Vesnin Sep 23 '16 at 18:44

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.