0

I have another copy of Tor browser on my PC and it plays SkillShare videos just fine.

But the one on VPS can't play giving an error:

"The video is bad or in a format that can't be played in your browser" media_err_decode

What can be causing the issue?

Everyone's help is greatly appreciated!

Thanks

  • It probably doesn't have the correct video codecs (codices?) available to decode it. You might need to install gstreamer plugins or whatever the system happens to use. – cacahuatl Aug 28 '16 at 22:51
  • Thanks for your reply. However I have installed Gstreamer, VLC and K-Lite Code Pack on the VPS machine but the videos on SkillShare still don't play. I'm getting the same error code and after I click the OK button the loading wheel just keeps on spinning. What can be different between Tor browser installed on my home PC and Tor installed on VPS? I have checked and the settings are the same. Both are the fresh installations. Thanks. – user3715235 Aug 29 '16 at 21:36
  • It could be that it's a non-free encoding method that can't be redistributed without a license. .e.g H.264 – cacahuatl Aug 30 '16 at 0:51
1

OK solved the problem after a thorough research. This update was required:

Update for Desktop Experience Decoder for Windows Server 2008 R2 (KB2483177)

https://www.microsoft.com/en-us/download/confirmation.aspx?id=13283

Thanks

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.