I'm having difficulty running Tor on Ubuntu (linux). This is a new problem, as I had been using it with no problems over the past year. Today, it will no longer start up when I click the icon. The icon appears in the taskbar for abut 30 seconds then disappears and that is it.

I've spent the least few hours searching for solutions, but none have worked. I've tried starting it through the terminal with numerous different commands and nothing works. It seems to think I have tor running already. I get this message (see below) even after a fresh uninstall/reinstall and cpu restart where I'm certain there is not tor running. This is the message I get in the terminal when I try to start tor:

PORTEGE-R835:~$ tor

Aug 20 19:39:42.810 [notice] Tor v0.2.7.6 (git-605ae665009853bd) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.2g-fips and Zlib 1.2.8.

Aug 20 19:39:42.810 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning

Aug 20 19:39:42.810 [notice] Read configuration file "/etc/tor/torrc".

Aug 20 19:39:42.815 [notice] Opening Socks listener on

Aug 20 19:39:42.815 [warn] Could not bind to Address already in use. Is Tor already running?

Aug 20 19:39:42.815 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.

Aug 20 19:39:42.815 [err] Reading config failed--see warnings above.

I can't find a way past this point. Any help would be greatly appreciated!! Thanks

  • 2
    It looks like tor is already running. It should run as a system service, it doesn't require that you run it from a terminal (infact, it's probably better than you don't run it from a terminal).
    – cacahuatl
    Aug 21, 2016 at 5:53
  • 2
    stop tor: sudo tor stop sudo /etc/init.d/tor stop OR: sudo killall tor Aug 21, 2016 at 8:14
  • 1
    It should also be noted that, by default, the system service will automatically start at boot. check ss -tlp to see what it bound to port 9050.
    – cacahuatl
    Aug 21, 2016 at 10:42
  • 1
    so something is already listening on that port, tor or otherwise. but that's why tor is failing to start from the terminal. What "icon" are you trying to use? Are you confusing Tor and Tor Browser?
    – cacahuatl
    Aug 22, 2016 at 0:36
  • 1
    So after killing tor process did you still get Address already in use. or is there any other message? Aug 22, 2016 at 8:33

2 Answers 2


Try this command

sudo netstat -plnt | fgrep 9050

and see if the port is being already used by tor. May be you have tor-browser installed and the tor package also.


In case you have started tor in another shell/job/somewhere on your device and forgot about it, and you simply want to kill all tor processes, (such that you can start your tor service again) you can run:

sudo killall tor

However, it would be better to use the command by PSN and then inspect which service is running on that port and to kill only that process instead of all tor processes. I currently don't have the command to only kill that particular process.

Note it could also be another process, like hosting a website, docker whatever, that is running on In that case the killall tor won't help because the other process is not a tor process so it won't be killed. That is why the method by PSN is better, it just lacks the stop command.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .