Trying to register new Facebook account using TOR browser. Security text check (captcha) are not displayed. Have tried using Facebook.com and m.Facebook.com and also the onion address. Same blank or null image. Audio captcha do not work too.

Thanks for help.

  • Are you using Tor browser bundle? It sounds like you have disabled JavaScript if you are. Click on the Tor Button (The green onion icon) on your Tor browser and select Privacy and Security Settings slide the "Security Level" slider to Medium-Low or Low to enable JavaScript. Also, you may wan to try a public wifi Or VPN without using Tor just for the registration. Aug 5, 2016 at 18:37
  • Gooe evening. javascript is enabled and security level is set as low. Just try to reset to default values and same result. I've already tested it using tails 2.4 and same result. Aug 5, 2016 at 18:49
  • Yes bundle if it means tor for windows. Aug 5, 2016 at 19:11
  • Please see my edit. Aug 6, 2016 at 2:21
  • "In my case a workaround is to click the Try another text button which then seems to produce a usable captcha." No longer a viable workaround. I used to use that, too. Facebook have the resources to get this right. I assume it's hostility to privacy? Dec 1, 2016 at 22:13

2 Answers 2


I can reproduce this, I think it's actually a bug in facebook's captcha mechanism.

From what I can see, it's requesting /tfbimage.php?captcha_challenge_code=foo&captcha_challenge_auth=bar and that request is itself receiving a redirect to /login.php?next=<the previous URL for the captcha image> which obviously doesn't return a captcha image.

Essentially it's asking you to login to retrieve the captcha (which you're probably getting...because you're not logged in. derp.)

Google's recaptcha did a similar thing previously on cloudflare, where requests for the captcha image got 403'd (Forbidden) so you couldn't fetch the mechanism to show you weren't a bot...because it thought you were a bot.

cc @alec-muffett

In my case a workaround is to click the Try another text button which then seems to produce a usable captcha.

There's not much else to be done from your side except try the workaround, it looks like an issue (or an intentional tactic? ¯\_(ツ)_/¯) on facebook's side


Another workaround is to modify the URL so that it begins with https://www.facebookcorewwwi.onion/ - that's Facebook's official .onion address, and the CAPTCHA works there.

  • I get the same problem I described on both .com and .onion
    – cacahuatl
    Sep 6, 2016 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .