I installed tor on a linux mint fresh install (18 - Sarah Cinnamon - to use with proxychains, with default settings too), with default settings. Tor service is started, but it does not appear listening on port 9050 when I put netstat -vantup (or ss). Iptables is disabled. When I try use proxychains (for example, proxychains firefox), the console shows me "|S-chain|-<>-<--timeout". In a station with Ubuntu, I did same installation, and works fine. Someone can help me to identify what can happend? Thanks in advance

  • is tor actually running? does it appear in the process list?
    – cacahuatl
    Aug 2 '16 at 19:50
  • also what does your tor log say? normally located at /var/log/tor/log
    – cacahuatl
    Aug 2 '16 at 22:26
  • Hi, thanks for reply.... 1-although the service appear as active ( /etc/init.d tor status - shows "active" ) , the process is not listed as " running " in htop #### 2 - at /var/log/tor/ was not log files, the folder is empty.... : (
    – Foschiera
    Aug 2 '16 at 22:38
  • there may be something broken in mints packaging then? you could try installing from the official tor repos using the upstream ubuntu codename that mint is based on, found with something like lsb_release -u -a then following the instructions on the torproject site for the ubuntu codename in question.
    – cacahuatl
    Aug 2 '16 at 22:58
  • Thanks again @canonizing-ironize... I tried install like instructions on torproject site, same problem. I added ubuntu repos on sources.list to download from these repos, but not working yet. Correcting my previous comment, the result of tor status is "active (exited)". As the os installation is "clean", I'll try install tor again from zero, including by source code, if does not work, I'll remake the os install. Thank you for attention!
    – Foschiera
    Aug 3 '16 at 16:38

I just had the exact same issue in the same Linux Mint version. According to this bug report, it affects all recent Debian releases: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=808296

The report suggests as a workaround to disable the apparmor config in the service file:

sudo mkdir /etc/systemd/system/tor@default.service.d/
sudo bash -c 'echo -e "[Service]\nAppArmorProfile=" > /etc/systemd/system/tor@default.service.d/override.conf'
sudo systemctl daemon-reload
sudo service tor restart

Worked for me ;-)


Not the answer you're looking for? Browse other questions tagged or ask your own question.