I was using Tor, for years, to download files to a web server. All of a sudden it has stopped working.

I've checked the Tor logs and there is nothing there.

Cleared iptables.

Running this command:

ps -elf | grep tor

shows all is well.

Running something like this just hangs:

curl --socks5-hostname https://domain.com

Any idea of how I might be able to test if my hosting company has blocked me from connecting to Tor?

  • have you tried any different SOCKS5 clients? try to enable verbose output in curl by addind --trace and paste a log here please
    – Alexey Vesnin
    Jul 17, 2016 at 6:06
  • If your host was blocking Tor, you'd see something in the logs. Can you give us more details? "stopped working" and "nothing there" aren't very descriptive of useful for diagnostic. Can you give us examples of errors received and what the Tor log actually contains and possibly the Tor config, e.g. do you have any accounting options set?
    – cacahuatl
    Jul 17, 2016 at 21:28
  • Whatever it was, it is now fixed. Lasted for several days. Jul 28, 2016 at 18:22

2 Answers 2


Most often how an ISP will try to block tor is by making it impossible to initiate a tor session. You can get around this with the pluggable transports. How some of these will work is that they make it look like you are talking to google or some other service and hide the tor communications within these sessions (That was an extremely basic explanation. it's cool stuff, I suggest everyone read about it). Here is a good talk about it by two tor devs.

How governments have tried to block Tor [28C3]

  • This doesn't actually answer the question of how to check if their host it blocking Tor.
    – cacahuatl
    Jul 20, 2016 at 1:46
  • @canonizingironize Oh whoops, one second, forgot to finish answering. Jul 20, 2016 at 1:55

I found the problem was resolved by deleting the Tor data-dir directory and then restarting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .