4


I just installed a Whonix Gateway VM on VirtualBox and setup my Debian VM to use the Whonix Gateway to connect to the internet.
So far all good. When I visit check.torproject.org it tells me I´m using Tor...
But somehow I am not able to access tor hidden services. For instance I am not able to visit the hidden wiki page through the web browser on my Debian VM.
My thought was as my connections are going through the Tor network anyways, it should be obvious I am able to connect to the hidden services...
Why is it not working (curl is saying 'Empty reply from server') and what do I have to do to make it work?

Thank You. :)

migrated from stackoverflow.com Jun 12 '16 at 20:18

This question came from our site for professional and enthusiast programmers.

1

I've yet to find a better way to do it, but the problem is that Firefox either can't resolve .onion domains, or resolution of .onion is blocked in newer versions of Firefox.

You'll need to configure your browser to use Tor's SOCKS proxy to surf .onion domains (Preferences >> Advanced >> Network >> Settings).

Firefox Proxy Settings Image

In your case, 127.0.0.1 might not be the SOCKS host, and would be the IP of your Whonix gateway server (and you'll need to see what port SOCKS is listening on).

Using cURL, you'd need to use curl --socks5-hostname 127.0.0.1:9050 http://site.onion/

0

Do you use firefox? If so, go to about:config, type onion in search field and set network.dns.blockDotOnion to false. (Also it's preferable to set network.http.referer.hideOnionSource to true)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.