I am using linuxmint, trying to run Tor browser from removable usb drive, don't want to leave it on HDD. Tried to unpack Tor browser to USB, but it wont work. 'start-tor-browser.desktop' is set to home folder on HDD. is it enough to change path in that file? I am new to linux, appreciate some help. Did someone tried this? Will it leave any trace on that machine?


Looking at the start-tor-browser.desktop (the one in tor-browser_$LANG/) it should execute itself based on the position that it is being run from and shouldn't need editing:

Exec=sh -c '"$(dirname "$*")"/Browser/start-tor-browser --detach || ([ ! -x "$(dirname "$*")"/Browser/start-tor-browser ] && "$(dirname "$*")"/start-tor-browser --detach)' dummy %k

You can just directly execute the start-tor-browser shell script and it should run fine, e.g. by running from a terminal:

/media/user/myusb/tor-browser_$LANG/Browser/start-tor-browser --detach

This should work for pretty much any directory, and it should contain itself to itself, this is that it will only affect things within its own folder.

However a strong note if you've strong requirements for anti-forensic properties is that the host operating system may swap out chunks of memory to disk (swap or pagefile.sys) or the entire contents of memory to disk (hibernation). This would necessarily include the contents of your browsing session and might violate any anti-forensic expectation you may have. If you have a strong requirement to run Tor Browser on Linux based system with anti-forensic properties, you should consider instead using the USB for use of the Tails operating system.

  • Thanks, in this case path was allready set to home dir, so I edited path to usb and started, got this "The application launcher "start-tor-browser.desktop" has not been marked as trusted. If you do not know the source of this file, launching it may be unsafe." When I click "Launch anyway", nothing happens...
    – Jim8645
    Jun 13 '16 at 1:02
  • I've no idea what all that "marked as trusted" stuff is about, something in your DE. Running the bash script from a terminal will work.
    – cacahuatl
    Jun 13 '16 at 2:47
  • I think I fixed it, it works now. I edited that config file and changed path. Thanks for info about swap etc. I am trying to use Whonix, I like idea of isolation. I think Whonix dont use swap?
    – Jim8645
    Jun 13 '16 at 17:58
  • You are running "Whonix" as a VM. If the OS you are using Whonix on has swap, it will swap out Whonix's memory to disk, hibernate, etc. It doesn't matter what's run inside the VM.
    – cacahuatl
    Jun 13 '16 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.