3

Finally yesterday I installed ubuntu 16.04 and after that I installed tor and obfs4. I add this line at the end of torrc file:

UseBridges 1
Bridge obfs4 82.243.119.185:990 B08238781C2CD80DBD95AEABEB6F6C75F2E2CEB6 cert=1udeMlFNs3sJ20zwpPE6nShZqqwDb3F1ET4KzfSfD+fktkue9zNx9H3t+yLCPAsg+6UTUA iat-mode=0
Bridge obfs4 192.36.31.173:42912 33DCA3BAD915D0F04CFAC6DF47B1BEB9E95E5C3A cert=3sBbfmp4fpIPpinXWbjZiVp+zWrK1kEUfmqNJNfszb8SXS+DeaVS4vQyvK7/fkU/TEPqVQ iat-mode=0
ClientTransportPlugin obfs4 exec /usr/bin/obfs4proxy --managed

But it didn't work, here is the log:

tail -f /var/log/tor/log
Jun 08 21:33:04.000 [notice] Delaying directory fetches: No running bridges
Jun 08 21:33:04.000 [notice] Signaled readiness to systemd
Jun 08 21:33:05.000 [warn] Could not launch managed proxy executable at '/usr/bin/obfs4proxy' ('Operation not permitted').
Jun 08 21:33:06.000 [notice] Bootstrapped 5%: Connecting to directory server
Jun 08 21:33:06.000 [warn] We were supposed to connect to bridge '82.243.119.185:990' using pluggable transport 'obfs4', but we can't find a pluggable transport proxy supporting 'obfs4'. This can happen if you haven't provided a ClientTransportPlugin line, or if your pluggable transport proxy stopped running.
Jun 08 21:33:06.000 [warn] Problem bootstrapping. Stuck at 5%: Connecting to directory server. (Can't connect to bridge; PT_MISSING; count 1; recommendation warn; host B08238781C2CD80DBD95AEABEB6F6C75F2E2CEB6 at 82.243.119.185:990)
Jun 08 21:33:06.000 [warn] We were supposed to connect to bridge '192.36.31.173:42912' using pluggable transport 'obfs4', but we can't find a pluggable transport proxy supporting 'obfs4'. This can happen if you haven't provided a ClientTransportPlugin line, or if your pluggable transport proxy stopped running.
Jun 08 21:33:06.000 [warn] Problem bootstrapping. Stuck at 5%: Connecting to directory server. (Can't connect to bridge; PT_MISSING; count 2; recommendation warn; host 33DCA3BAD915D0F04CFAC6DF47B1BEB9E95E5C3A at 192.36.31.173:42912)
Jun 08 21:33:06.000 [warn] We were supposed to connect to bridge '94.242.249.2:47282' using pluggable transport 'obfs4', but we can't find a pluggable transport proxy supporting 'obfs4'. This can happen if you haven't provided a ClientTransportPlugin line, or if your pluggable transport proxy stopped running.
Jun 08 21:33:06.000 [warn] Problem bootstrapping. Stuck at 5%: Connecting to directory server. (Can't connect to bridge; PT_MISSING; count 3; recommendation warn; host 52C5F1C15DCF6DAC47556EC1D4EC4BE5B24BDEC7 at 94.242.249.2:47282)

I'm beginner could you please help me where is the problem?

2
  • Do you have obfs4proxy installed? What is the output of ls -l /usr/bin/obfs4proxy?
    – Jens Kubieziel
    Commented Jun 9, 2016 at 13:22
  • Yes I installed that. '-rwxr-xr-x 1 root root 6485536 مارس 22 16:09 /usr/bin/obfs4proxy' Commented Jun 9, 2016 at 17:46

2 Answers 2

5

In your torrc there is the line

ClientTransportPlugin obfs4 exec /usr/bin/obfs4proxy --managed

Furthermoer the log file states:

Jun 08 21:33:05.000 [warn] Could not launch managed proxy executable at '/usr/bin/obfs4proxy' ('Operation not permitted').

According to the manpage of obfs4proxy there is no option --managed. This was used for obfsproxy. So if you delete the option --managed and restart Tor, it will start and use obfs4proxy.

2

You could fix your problem with apparmor like this:

First open /etc/apparmor.d/abstractions/tor with your favorite editor (with root user)

  • sudo gedit /etc/apparmor.d/abstractions/tor

Then change the /usr/bin/obfs4proxy PUx, to /usr/bin/obfs4proxy ix, and save it!

And after that reboot

3
  • Could you explain what the change from PUx to ix does? It might help future readers.
    – Jens Kubieziel
    Commented Jun 16, 2016 at 12:48
  • @JensKubieziel Its about permissions.For example PU means: **P** - exec to profile that matches executable name, with environment variable scrubbing. **U** - exec to unconfined, with environment variable scrubbing. For more look at [wiki.apparmor.net/index.php/… Core Policy Reference) Commented Jun 16, 2016 at 15:38
  • @FarbodAhmadian /usr/bin/obfsproxy PUx, /usr/bin/obfs4proxy ix, this is mine and still not work !
    – alireza
    Commented Oct 22, 2016 at 20:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .