I've updated to the latest Tor Browser Bundle but the option to turn off JavaScript seems to have disappeared. What is the correct way to turn off JavaScript now? I tried to set JavaScript enabled to false in about:config but several sites still report JavaScript is active on my browser. How do I turn it off?

  • Click on the S! next to onion below Tor browser tab and then click on disable globally.
    – user1318
    Commented Mar 8, 2014 at 5:50
  • Navigate to: about:config .Then search for 'javascript' and set javascript.enabledto false.
    – gjerich
    Commented Jan 16, 2019 at 11:46
  • Noscript options>advanced>Override Tor browsers level preset
    – Ghost
    Commented Jun 22, 2019 at 14:45

3 Answers 3


Do you have NoScript set to globally forbid all Javascript? NoScript in Tor Browser 3.5 seems to allow scripts by default, so you might want to check if it is overriding your Firefox settings. Click on the NoScript icon on the toolbar and select "Forbid scripts globally". You might also want to go to the "Options" (in the same menu) and edit the Whitelist section.


Mozilla removed option to disable JavaScript in Firefox version 23. Since Tor Browser 3.5+ series based on Firefox ESR 24, it shipped without this switch.

In addition to Mike's answer, you can also consult to How do I disable JavaScript? section on Tor Browser Bundle 3 FAQ.

Also, setting on javascript.enabled to false on about:config should actually disable JavaScript. Could you please check if your preference is stored correctly?

Also please note that there is a slight possibility that sites report your JavaScript as active could be simply wrong. You can test it on the following sites:

  • Thanks for this answer! Although we encourage you to cite links as part of an answer, it is good practise to summarise the content, or quote relevant excepts from the pgae, so that the answer can stand alone without the links working - this is useful if, for example, the webpage gets removed or changed. Commented Dec 21, 2013 at 12:56

The actual Tor browser bundle has an option in the plugins window to activate the NoScript plugin so you only need to restart the browser with that program.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .