Some if not all of my projects contains folders with symbols in them. Often a leading # hash character or $ dollar sign. When i try to set such a directory within a path like so;

DataDirectory Y:\Workspace\$projectFiles\\#include\alpha\data

tor.exe only gets everything up until the eol char before continuing like so;

DataDirectory Y:\Workspace\$projectFiles\

could someone add either a

eolChar 1|0


eolChar *char*

to either options or as a command-line switch? Or a better way to define paths like a dedicated paths file relative to tor.exe location.

1 Answer 1


edited to provide the correct answer only, rather than a hacky workaround

Encapsulate the whole directory path in " characters.

DataDirectory "Y:\\Workspace\\$projectFiles\\#include\\alpha\\data"

if you wanted to put quotes inside of your directory name, you could by using C style escaping: \"

DataDirectory "Y:\\Workspace\\\"$projectFiles\"\\#include\\alpha\\data"
  • yes i know, i use it myself all the time, and in my codes i make sure there is no such thing as an invalid directory character :P but then again i am working in windows. no command flags there. do you have any idea on how to replicate that behavior in a windows command shell?
    – TRSyntax
    May 23, 2016 at 23:57
  • Windows does indeed support command line arguments. start -> run -> cmd.exe -> cd path\to\tor -> tor.exe --datadirectory ...
    – cacahuatl
    May 24, 2016 at 0:39
  • i know m8. like the title implies; "torcc directory paths not parsed" that particular option is read from a torcc options file. well all path related options are. but i notice you escape the hash symbol in your command line? '\#' , is this a linux shell feature or something i can use in a options file? maybe its a variable? confused
    – TRSyntax
    May 24, 2016 at 1:03
  • I'll formulate a full answer I guess...
    – cacahuatl
    May 24, 2016 at 1:26
  • Please see my update for a proper solution, it is entirely possible. Had to read the source.
    – cacahuatl
    May 24, 2016 at 1:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .