2

I'm trying to install obfs4 support on a bridge. But I cant find the right package to install. Can anyone help me find it?

Running archlinux for arm on a pogoplug v2

Thanks!

1
  • a source compilation is your way : GO language + OBFS4
    – Alexey Vesnin
    Commented May 8, 2016 at 15:26

1 Answer 1

1

You should be able to build it natively, as per the README here or you can try to cross-compile from another architecture to armv5 using the method here.

For example

    export GOARCH=arm
    export GOARM=5
    mkdir ~/goarm
    export GOPATH=~/goarm
    go get -u github.com
    go get git.torproject.org/pluggable-transports/obfs4.git/obfs4proxy

should result in an ARMv5 obfs4proxy binary in ~/goarm/bin/obfs4proxy

edit: Looking at some of the dependencies, there maybe issues with cryptographic operations that have been optimized in assembly. It does seem to have ARM assembly though.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .