1

I am trying to sync the time on both whonix gateway and workstation but am getting the following connectivity errors upon running whonixcheck with the verbose flag set. On the gateway I get:

$ whonixcheck --verbose

whonix check 1

whonix check 2

Next, when running arm on the gateway there seems to be no connection to the tor network:

whonix arm

Following the steps suggested in the answer of this question the log files are:

tail -f /var/log/sdwdate.log

sdwupdate

When running timesync on the gateway I get:

timesync 1 timesync 2 timesync 3 timesync 4

When running:

tail -f -n 20 /var/log/sdwdate.log

The following are shown:

timesync 5

What is weird is that I cannot set the hwclock.

Setting the time by running:

# date +%T -s "01:01:30"

is reset after a reboot (I'm running whonix in VirtualBox on a Win7 host machine).

After, the time update the hwclock gives the same output as prior to setting the time.

I'm not sure how relevant this is, but a few days ago I made a dual boot setup (debian/win7) and booted in debian. I also disabled the UEFI boot option in BIOS in order to be able to boot from a USB stick and install debian.

Why isn't whonix able to sync its time?

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.