5

I'm a beginner who need a little help. I got stuck while i was trying to setup my hidden service.

I'm on a Mac (EL Capitan) running Windows 7 on Parallels Desktop virtual machine. I have my wampserver 2.5 running quite nice (honestly i have a little issue: if i place my site to the www folder it wont load for the localhost command in the browser, only when i give the exact location like localhost.index.html, i don't think its connected to my tor problem :) ) or? :)

Tor Browser run just fine, but when i add this line:

# Hidden Service
HiddenServiceDir C:\Users\UserName\tor_service
HiddenServicePort 80 127.0.0.1:80

I got an error message:

Tor unexpectedly exited. This might be due to a bug in Tor itself, another program on your system, or faulty hardware. Until you restart Tor, the Tor Browser will not able to reach any websites. If the problem persists, please send a copy of your Tor Log to the support team. Restarting Tor will not close your browser tabs.

If i make any changes in the torrc file, this problem occurs. When i delete the added lines, the problem disappear.

Any idea?

  • ohh one thing! Someone said it might be a permission issue, so Tor cant create the file, but im lost at this point. – Pterson Apr 12 '16 at 21:58
  • Try running tor.exe --verify-config and see which line it thinks is the problem. (I can't immediately tell what the problem is... ) But yes, check that UserName has permissions to run Tor in the first place. (i.e. This user must match the user that downloaded and extracted/installed the Tor folder.) – Richard Horrocks Apr 12 '16 at 22:05
  • thank you very much for your answer, however i couldnt run tor.exe --verify-config in the command prompt either. it gives me the same result as i mentioned. Im still confused by this permission issue. If i can run tor with the original settings in the torrc file, why i cant do again after i edited it a little with the hidden services lines? – Pterson Apr 13 '16 at 9:31
  • Because you're adding a new location - C:\Users\UserName\tor_service - that Tor must be able to read. If the permissions on C:\Users\UserName\tor_service don't allow read/execute, then Tor will struggle. So --verify config gives no output at all? – Richard Horrocks Apr 13 '16 at 9:55
  • on windows I found the answer here: tor.stackexchange.com/a/16015/17207 – JinSnow Oct 31 '17 at 21:45
1

Make sure you have the directory C:\Users\UserName\tor_service and tor has read, write, and execute permissions.

  • Thank You very much for the help! The permission issue is solved and its working! Bless you all! :) – Pterson Apr 14 '16 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.