Say one's using GNU/Linux with a Tor daemon setup on a given local port (which happens not to be 9050). Web browsing traffic currently goes like this: vanilla Firefox -> Privoxy -> Tor.

Say one would like to replace Firefox with the Tor browser from the 'hardened' official TBB package. As the browser gets invoked via the launcher script, it starts its own bundled Tor proxy and it works alright. But telling it to use Privoxy or even existing Tor directly (via proxy settings) won't make it connect to the Internet.

How to configure the Tor browser to use already available Tor channels on the system?

1 Answer 1


Go to about:addons, click on the Extensions tab, and disable the Torbutton and TorLauncher settings. After restarting the Tor Browser, go to about:preferences#advanced, select the Network tab, and configure your proxy.

If you still want to be able to change your Privacy and Security settings, you can keep the Torbutton extension enabled. It will just have an X on it indicating that the browser is not connected to Tor. (Torbutton checks for the bundled proxy)

  • Thank you! Sounds exactly like what I need, will test that ASAP on my laptop. Out of curiosity, did you figure the procedure out yourself or did you stumble on documentation I couldn't find?
    – dummydev
    Apr 21, 2016 at 8:52
  • If you go into the proxy settings of the Tor Browser, it tells you to disable the Tor Button extension to change settings. I just guessed the function of the TorLauncher extension. Apr 22, 2016 at 1:30
  • Is there some way to still update the Tor Browser? I tried keeping the torbutton enabled and setting "extensions.torbutton.update_torbutton_via_tor" to false, but I'm still getting an error when I try to check for updates: "Data transfer was interrupted". Everything else works fine otherwise.
    – M.K.
    Nov 25, 2016 at 12:02
  • great answer. my question isn't kind of related (kind of), if possible I would love to have your feedback on it: tor.stackexchange.com/questions/14650/…
    – Webeng
    Apr 26, 2017 at 6:41
  • My test result is you need to disable the Tor button extension, otherwise your proxy configuration will not work and get prompt of Unable to find the proxy server. I test this on TBB 8.0.8.
    – illiterate
    Apr 3, 2019 at 12:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .